Wind River Support Network

HomeDefectsLIN5-23149
Fixed

LIN5-23149 : Security Advisory - strongswan - CVE-2017-9023

Created: Jun 4, 2017    Updated: May 29, 2018
Resolved Date: Jul 20, 2017
Found In Version: 5.0.1.39
Fix Version: 5.0.1.41
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

It was found that ASN.1 CHOICE types are not correctly handled by the ASN.1 parser when parsing X.509 certificates with extensions that use such types. This could lead to infinite looping of the thread parsing a specifically crafted certificate.

ttps://nvd.nist.gov/vuln/detail/CVE-2017-9023

Other Downloads


Live chat
Online