Wind River Support Network

HomeDefectsLIN5-23127
Fixed

LIN5-23127 : Security Advisory - gnutls&libtasn1 - CVE-2017-6891

Created: May 25, 2017    Updated: May 29, 2018
Resolved Date: Jul 20, 2017
Found In Version: 5.0.1.39
Fix Version: 5.0.1.41
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Two errors in the asn1_find_node() function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility.

https://nvd.nist.gov/vuln/detail/CVE-2017-6891

Other Downloads


Live chat
Online