Wind River Support Network

HomeDefectsLIN5-23102
Fixed

LIN5-23102 : Security Advisory - linux - CVE-2017-1000363

Created: May 16, 2017    Updated: May 29, 2018
Resolved Date: Aug 16, 2017
Found In Version: 5.0.1.39
Fix Version: 5.0.1.41
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The lp_setup() code doesn't apply any bounds checking when passing "lp=none", and only in this case, resulting in an overflow of the parport_nr[] array. All versions in Git history are affected.

https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/char-misc.git/commit/?h=char-misc-linus&id=3e21f4af170bebf47c187c1ff8bf155583c9f3b1

https://nvd.nist.gov/vuln/detail/CVE-2017-1000363

Other Downloads


Live chat
Online