Wind River Support Network

HomeDefectsLIN5-22920
Fixed

LIN5-22920 : Security Advisory - apache - CVE-2016-0736

Created: Apr 18, 2017    Updated: May 29, 2018
Resolved Date: Jul 20, 2017
Found In Version: 5.0.1.39
Fix Version: 5.0.1.41
Severity: Low
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Prior to Apache HTTP release 2.4.25, mod_sessioncrypto was encrypting its data/cookie using the configured ciphers with possibly either CBC or ECB modes of operation (AES256-CBC by default), hence no selectable or builtin authenticated encryption. This made it vulnerable to padding oracle attacks, particularly with CBC. An authentication tag (SipHash MAC) is now added to prevent such attacks. 

https://httpd.apache.org/security/vulnerabilities_24.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0736

Other Downloads


Live chat
Online