Wind River Support Network

HomeDefectsLIN5-22350
Fixed

LIN5-22350 : Security Advisory - ruby - CVE-2016-2339

Created: Jan 12, 2017    Updated: May 29, 2018
Resolved Date: Jan 16, 2017
Found In Version: 5.0.1.38
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

An exploitable heap overflow vulnerability exists in the Fiddle::Function.new initialize function functionality of Ruby. In Fiddle::Function.new initialize heap buffer arg_types allocation is made based on args array length. Specially constructed object passed as element of args array can increase this array size after mentioned allocation and cause heap overflow.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-2339

Other Downloads


Live chat
Online