Wind River Support Network

HomeDefectsLIN5-22314
Fixed

LIN5-22314 : Security Advisory - linux - CVE-2016-9793

Created: Dec 28, 2016    Updated: May 29, 2018
Resolved Date: Jan 5, 2017
Found In Version: 5.0.1.37
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The sock_setsockopt function in net/core/sock.c in the Linux kernel before 4.8.14 mishandles negative values of sk_sndbuf and sk_rcvbuf, which allows local users to cause a denial of service (memory corruption and system crash) or possibly have unspecified other impact by leveraging the CAP_NET_ADMIN capability for a crafted setsockopt system call with the (1) SO_SNDBUFFORCE or (2) SO_RCVBUFFORCE option.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-9793

Other Downloads


Live chat
Online