Wind River Support Network

HomeDefectsLIN5-22258
Fixed

LIN5-22258 : Security Advisory - postgresql - CVE-2016-5423

Created: Dec 15, 2016    Updated: May 29, 2018
Resolved Date: Jan 13, 2017
Found In Version: 5.0.1.37
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 allow remote authenticated users to cause a denial of service (NULL pointer dereference and server crash), obtain sensitive memory information, or possibly execute arbitrary code via (1) a CASE expression within the test value subexpression of another CASE or (2) inlining of an SQL function that implements the equality operator used for a CASE expression involving values of different types.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5423

Other Downloads


Live chat
Online