Wind River Support Network

HomeDefectsLIN5-22186
Fixed

LIN5-22186 : Security Advisory - linux - CVE-2016-8650

Created: Dec 15, 2016    Updated: May 29, 2018
Resolved Date: Jan 17, 2017
Found In Version: 5.0.1.37
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The mpi_powm function in lib/mpi/mpi-pow.c in the Linux kernel through 4.8.11 does not ensure that memory is allocated for limb data, which allows local users to cause a denial of service (stack memory corruption and panic) via an add_key system call for an RSA key with a zero exponent.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-8650

Other Downloads


Live chat
Online