Wind River Support Network

HomeDefectsLIN5-22180
Fixed

LIN5-22180 : Security Advisory - postgresql - CVE-2016-5424

Created: Dec 15, 2016    Updated: May 29, 2018
Resolved Date: Jan 8, 2017
Found In Version: 5.0.1.37
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x before 9.4.9, and 9.5.x before 9.5.4 might allow remote authenticated users with the CREATEDB or CREATEROLE role to gain superuser privileges via a (1)  (double quote), (2) \ (backslash), (3) carriage return, or (4) newline character in a (a) database or (b) role name that is mishandled during an administrative operation.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5424

Other Downloads


Live chat
Online