Wind River Support Network

HomeDefectsLIN5-22157
Fixed

LIN5-22157 : Security Advisory - libtiff - CVE-2016-9535

Created: Nov 24, 2016    Updated: May 29, 2018
Resolved Date: Dec 8, 2016
Found In Version: 5.0.1.37
Fix Version: 5.0.1.39
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

tif_predict.h and tif_predict.c in libtiff 4.0.6 have assertions that can lead to assertion failures in debug mode, or buffer overflows in release mode, when dealing with unusual tile size like YCbCr with subsampling. Reported as MSVR 35105, aka Predictor heap-buffer-overflow.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-9535

Other Downloads


Live chat
Online