Wind River Support Network

HomeDefectsLIN5-22076
Fixed

LIN5-22076 : Security Advisory - libcurl - CVE-2016-8622

Created: Oct 31, 2016    Updated: Oct 18, 2018
Resolved Date: Nov 8, 2016
Found In Version: 5.0.1.37
Fix Version: 5.0.1.38
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

VULNERABILITY
-------------

The URL percent-encoding decode function in libcurl is called
`curl_easy_unescape`. Internally, even if this function would be made to
allocate a unscape destination buffer larger than 2GB, it would return that
new length in a signed 32 bit integer variable, thus the length would get
either just truncated or both truncated and turned negative. That could then
lead to libcurl writing outside of its heap based buffer.

This can be triggered by a user on a 64bit system if the user can send in a
custom (very large) URL to a libcurl using program.

We are not aware of any exploit of this flaw.

INFO
----

The Common Vulnerabilities and Exposures (CVE) project has assigned the name
CVE-2016-XXXX to this issue.

AFFECTED VERSIONS
-----------------

This flaw exists in the following curl versions

- Affected versions: curl 7.24.0 to and including 7.50.3
- Not affected versions: curl < 7.24.0 and curl >= 7.51.0

libcurl is used by many applications, but not always advertised as such!

THE SOLUTION
------------

In version 7.51.0, the parser function is fixed.

A [patch for CVE-2016-XXXX](https://curl.haxx.se/s3c/H.patch) is available.

RECOMMENDATIONS
---------------

We suggest you take one of the following actions immediately, in order of
preference:

  A - Upgrade curl and libcurl to version 7.51.0

  B - Apply the patch to your version and rebuild

TIME LINE
---------

It was first reported to the curl project on September 23 by Cure53.

We contacted distros@openwall on October 19.

curl 7.51.0 was released on November 2 2016, coordinated with the publication
of this advisory.

Other Downloads


Live chat
Online