Wind River Support Network

HomeDefectsLIN5-21985
Fixed

LIN5-21985 : Security Advisory - libcurl - CVE-2016-7141

Created: Sep 22, 2016    Updated: May 29, 2018
Resolved Date: Oct 18, 2016
Found In Version: 5.0.1.37
Fix Version: 5.0.1.38
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

After testing original CVE-2016-5420 patch, it was discovered that libcurl built on top of NSS (Network Security Services) still incorrectly re-uses client certificates if a certificate from file is used for one TLS connection but no certificate is set for a subsequent TLS connection.

The original patch for CVE-2016-5420 has been amended to also contain the attached patch:

Other Downloads


Live chat
Online