Wind River Support Network

HomeDefectsLIN5-21984
Fixed

LIN5-21984 : Security Advisory - libcurl - CVE-2016-7167

Created: Sep 22, 2016    Updated: May 29, 2018
Resolved Date: Oct 18, 2016
Found In Version: 5.0.1.37
Fix Version: 5.0.1.38
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

It was found that provided string length arguments in four libcurl functions curl_escape(), curl_easy_escape(), curl_unescape and curl_easy_unescape were not properly checked and due to arithmetic in the functions, passing in the length 0xffffffff (2^32-1 or UINT_MAX or even just -1) would end up causing an allocation of zero bytes of heap memory that curl would attempt to write gigabytes of data into.

Other Downloads


Live chat
Online