Wind River Support Network

HomeDefectsLIN5-21928
Fixed

LIN5-21928 : Security Advisory - cracklib - CVE-2016-6318

Created: Sep 11, 2016    Updated: May 29, 2018
Resolved Date: Oct 17, 2016
Found In Version: 5.0.1.37
Fix Version: 5.0.1.38
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Stack-based buffer overflow in the FascistGecosUser function in lib/fascist.c in cracklib allows local users to cause a denial of service (application crash) or gain privileges via a long GECOS field, involving longbuffer.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-6318

Other Downloads


Live chat
Online