Wind River Support Network

HomeDefectsLIN5-21908
Fixed

LIN5-21908 : Security Advisory - openssl - CVE-2016-2182

Created: Aug 26, 2016    Updated: May 29, 2018
Resolved Date: Aug 29, 2016
Found In Version: 5.0.1.36
Fix Version: 5.0.1.38
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

An out-of-bounds write vulnerability was found to be caused by not checking errors in BN_bn2dec(). If an oversize BIGNUM is presented to BN_bn2dec() it can cause BN_div_word() to fail and not reduce the value of 't' resulting in OOB writes to the bn_data buffer and eventually crashing.

https://bugzilla.redhat.com/show_bug.cgi?id=1367340

Steps to Reproduce

-

Security Notices


Other Downloads


Live chat
Online