Wind River Support Network

HomeDefectsLIN5-21715
Fixed

LIN5-21715 : Security Advisory - expat - CVE-2016-5300

Created: Jun 29, 2016    Updated: May 29, 2018
Resolved Date: Jul 20, 2016
Found In Version: 5.0.1.36
Fix Version: 5.0.1.37
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The XML parser in Expat does not use sufficient entropy for hash initialization, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted identifiers in an XML document.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0876.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5300

Other Downloads


Live chat
Online