Wind River Support Network

HomeDefectsLIN5-21470
Fixed

LIN5-21470 : Security Advisory - wpa_supplicant - CVE-2016-4477

Created: May 17, 2016    Updated: May 29, 2018
Resolved Date: Jul 13, 2016
Found In Version: 5.0.1.35
Fix Version: 5.0.1.37
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

wpa_supplicant 0.4.0 through 2.5 does not reject \n and \r characters in passphrase parameters, which allows local users to trigger arbitrary library loading and consequently gain privileges, or cause a denial of service (daemon outage), via a crafted (1) SET, (2) SET_CRED, or (3) SET_NETWORK command.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-4477

Other Downloads


Live chat
Online