Wind River Support Network

HomeDefectsLIN5-21304
Fixed

LIN5-21304 : Security Advisory - quagga - CVE-2016-2342

Created: Mar 29, 2016    Updated: May 29, 2018
Resolved Date: Apr 6, 2016
Found In Version: 5.0.1.35
Fix Version: 5.0.1.36
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The bgp_nlri_parse_vpnv4 function in bgp_mplsvpn.c in the VPNv4 NLRI parser in bgpd in Quagga before 1.0.20160309, when a certain VPNv4 configuration is used, relies on a Labeled-VPN SAFI routes-data length field during a data copy, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted packet.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-2342

Other Downloads


Live chat
Online