Wind River Support Network

HomeDefectsLIN5-21253
Fixed

LIN5-21253 : Security Advisory - openssl - CVE-2016-2842

Created: Mar 9, 2016    Updated: May 29, 2018
Resolved Date: Mar 17, 2016
Found In Version: 5.0.1.34
Fix Version: 5.0.1.36
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The doapr_outch function in crypto/bio/b_print.c in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g does not verify that a certain memory allocation succeeds, which allows remote attackers to cause a denial of service (out-of-bounds write or memory consumption) or possibly have unspecified other impact via a long string, as demonstrated by a large amount of ASN.1 data, a different vulnerability than CVE-2016-0799.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2842

Steps to Reproduce

-

Other Downloads


Live chat
Online