Wind River Support Network

HomeDefectsLIN5-21213
Fixed

LIN5-21213 : Security Advisory - socat - CVE-2016-2217

Created: Feb 24, 2016    Updated: May 29, 2018
Resolved Date: Mar 6, 2016
Found In Version: 5.0.1.34
Fix Version: 5.0.1.36
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

It was found that in the OpenSSL address implementation the hard coded 1024 bit DH p parameter was not prime. The effective cryptographic strength of a key exchange using these parameters was weaker than the one one could get by using a prime p, making easier for eavesdropper to recover the shared secret from a key exchange that uses them.

Affected versions are 1.7.3.0 and 2.0.0-b8.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2217

Other Downloads


Live chat
Online