Wind River Support Network

HomeDefectsLIN5-21098
Fixed

LIN5-21098 : Security Advisory - ecryptfs-utils - CVE-2016-1572

Created: Jan 27, 2016    Updated: May 29, 2018
Resolved Date: Mar 7, 2016
Previous ID: OVP-2718
Found In Version: 5.0.1.34
Fix Version: 5.0.1.36
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

mount.ecryptfs_private.c in eCryptfs-utils does not validate mount destination filesystem types, which allows local users to gain privileges by mounting over a nonstandard filesystem, as demonstrated by /proc/$pid.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1572

Other Downloads


Live chat
Online