Wind River Support Network

HomeDefectsLIN5-20678
Fixed

LIN5-20678 : Security Advisory - apache - CVE-2015-3185

Created: Aug 2, 2015    Updated: Dec 19, 2017
Resolved Date: Aug 9, 2015
Found In Version: 5.0.1.29
Fix Version: 5.0.1.30
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The ap_some_auth_required function in server/request.c in the Apache HTTP Server 2.4.x before 2.4.14 does not consider that a Require directive may be associated with an authorization setting rather than an authentication setting, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging the presence of a module that relies on the 2.2 API behavior.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-3185

Other Downloads


Live chat
Online