Wind River Support Network

HomeDefectsLIN5-20611
Fixed

LIN5-20611 : Security Advisory - Hostapd & wpa_supplicant. - CVE-2015-4142

Created: Jun 30, 2015    Updated: Dec 19, 2017
Resolved Date: Aug 3, 2015
Found In Version: 5.0.1.27
Fix Version: 5.0.1.30
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-4142

Other Downloads


Live chat
Online