Wind River Support Network

HomeDefectsLIN5-20610
Fixed

LIN5-20610 : Security Advisory - Hostapd & wpa_supplicant. - CVE-2015-4141

Created: Jun 30, 2015    Updated: Dec 19, 2017
Resolved Date: Aug 3, 2015
Found In Version: 5.0.1.27
Fix Version: 5.0.1.30
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-4141

Other Downloads


Live chat
Online