Wind River Support Network

HomeDefectsLIN5-20518
Fixed

LIN5-20518 : Security Advisory - postgresql - CVE-2015-0241

Created: Jun 14, 2015    Updated: Dec 19, 2017
Resolved Date: Jul 8, 2015
Previous ID: LIN4-32743
Found In Version: 5.0.1.26
Fix Version: 5.0.1.29
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The PostgreSQL project reports the following issue:

When to_char() processes a numeric formatting template calling for a large number of digits, PostgreSQL would read past the end of a buffer. When processing a crafted timestamp formatting template, PostgreSQL would write past the end of a buffer. Either case could crash the server. We have not ruled out the possibility of attacks that lead to privilege escalation, though they seem unlikely.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0241

Other Downloads


Live chat
Online