Wind River Support Network

HomeDefectsLIN5-20394
Fixed

LIN5-20394 : Security Advisory - ppp - CVE-2015-3310

Created: May 3, 2015    Updated: Dec 19, 2017
Resolved Date: Jun 16, 2015
Found In Version: 5.0.1.25
Fix Version: 5.0.1.28
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Buffer overflow in the rc_mksid function in plugins/radius/util.c in Paul's PPP Package (ppp) 2.4.6 and earlier, when the PID for pppd is greater than 65535, allows remote attackers to cause a denial of service (crash) via a start accounting message to the RADIUS server.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-3310

Other Downloads


Live chat
Online