Wind River Support Network

HomeDefectsLIN5-20314
Fixed

LIN5-20314 : Security Advisory - php - CVE-2015-2787

Created: Apr 16, 2015    Updated: Dec 19, 2017
Resolved Date: Apr 26, 2015
Found In Version: 5.0.1.25
Fix Version: 5.0.1.26
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Use-after-free vulnerability in the process_nested_data function in ext/standard/var_unserializer.re in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages use of the unset function within an __wakeup function, a related issue to CVE-2015-0231.<a href=http://cwe.mitre.org/data/definitions/416.html>CWE-416: Use After Free</a>

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-2787

Other Downloads


Live chat
Online