Wind River Support Network

HomeDefectsLIN5-20193
Fixed

LIN5-20193 : Security Advisory - linux - CVE-2014-9644

Created: Mar 15, 2015    Updated: Dec 19, 2017
Resolved Date: May 25, 2015
Found In Version: 5.0.1
Fix Version: 5.0.1.27
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Kernel

Description

The Crypto API in the Linux kernel before 3.18.5 allows local users to load arbitrary kernel modules via a bind system call for an AF_ALG socket with a parenthesized module template expression in the salg_name field, as demonstrated by the vfat(aes) expression, a different vulnerability than CVE-2013-7421.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-9644

Other Downloads


Live chat
Online