Wind River Support Network

HomeDefectsLIN5-2002
Fixed

LIN5-2002 : Missing dependencies in perl-modules RPM package

Created: Apr 23, 2013    Updated: Dec 19, 2017
Resolved Date: Jul 29, 2013
Found In Version: 5.0.1
Fix Version: 5.0.1.6
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

As of WRL 5.0.1.2 the perl-modules package lists the following two dependencies: perl-module-config-heavy and perl-module-encode-.debug (there IS a dot before 'debug').

These dependencies, RPM packages, are not generated by the WRL build.

Workaround

None available at the moment.

Steps to Reproduce

Inspect the RPM package created on any WRL build:

$ rpm -qpR export/RPMS/x86_64/perl-modules-5.14.2-r8.1.x86_64.rpm | grep -e config-heavy -e encode-.debug
perl-module-config-heavy
perl-module-encode-.debug

These two modules are nowhere to be found in the RPMS directory.

Other Downloads


Live chat
Online