Wind River Support Network

HomeDefectsLIN5-19988
Fixed

LIN5-19988 : Security Advisory - openssl - CVE-2015-0204

Created: Jan 14, 2015    Updated: Dec 19, 2017
Resolved Date: Jan 17, 2015
Found In Version: 5.0.1.22
Fix Version: 5.0.1.23
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-0204

Other Downloads


Live chat
Online