Wind River Support Network

HomeDefectsLIN5-19919
Fixed

LIN5-19919 : libc6-locale-* RPM files have wrong license info

Created: Dec 16, 2014    Updated: Dec 19, 2017
Resolved Date: Dec 21, 2014
Found In Version: 5.0.1.20
Fix Version: 5.0.1.22
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Toolchain

Description

Though the package license for wrl-glibc-prebuilt is correct, the actually RPM files for glibc locale, i.e. libc6-locale-*.rpm, carry improper license info.

Steps to Reproduce

$ WRL5/wrlinux/configure --enable-board=intel-atom \
  --enable-rootfs=glibc-core --enable-kernel=preempt-rt \
  --enable-build=production --enable-parallel-pkgbuilds=6 \
  --enable-jobs=4
$ echo 'IMAGE_LINGUAS = "en-us en-gb de-de zh-cn"' >> local.conf
$ make fs
$ cd export/RPMS/atom
$ rpm -qp --qf '%{name}:%{license}\n' libc6-locale-de-2.15-r14.atom.rpm 
warning: libc6-locale-de-2.15-r14.atom.rpm: Header V4 DSA/SHA1 Signature, key ID 3be0cf42: NOKEY
libc6-locale-de:GPL-3.0-with-GCC-exception & GPLv3 & GPLv2 & LGPLv2.1

Other Downloads


Live chat
Online