Wind River Support Network

HomeDefectsLIN5-19817
Fixed

LIN5-19817 : Security Advisory - ppp - CVE-2014-3158

Created: Dec 1, 2014    Updated: Dec 19, 2017
Resolved Date: Dec 23, 2014
Found In Version: 5.0.1.21
Fix Version: 5.0.1.22
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to access privileged options via a long word in an options file, which triggers a heap-based buffer overflow that [corrupts] security-relevant variables.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3158

Other Downloads


Live chat
Online