Wind River Support Network

HomeDefectsLIN5-19719
Fixed

LIN5-19719 : Security Advisory - libxml2 - CVE-2014-3660

Created: Nov 16, 2014    Updated: Dec 19, 2017
Resolved Date: Jan 9, 2015
Found In Version: 5.0.1.22
Fix Version: 5.0.1.23
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

parser.c in libxml2 before 2.9.2 does not properly prevent entity expansion even when entity substitution has been disabled, which allows context-dependent attackers to cause a denial of service (CPU consumption) via a crafted XML document containing a large number of nested entity references, a variant of the billion laughs attack.<a href=http://cwe.mitre.org/data/definitions/611.html target=_blank>CWE-611: Improper Restriction of XML External Entity Reference ('XXE')</a>

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3660

Other Downloads


Live chat
Online