Wind River Support Network

HomeDefectsLIN5-19621
Fixed

LIN5-19621 : Security Advisory - gpgme - CVE-2014-3564

Created: Oct 30, 2014    Updated: Dec 19, 2017
Resolved Date: Dec 22, 2014
Found In Version: 5.0.1.21
Fix Version: 5.0.1.22
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to different line lengths in a specific order.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3564

Other Downloads


Live chat
Online