Wind River Support Network

HomeDefectsLIN5-19581
Fixed

LIN5-19581 : openssl revision number is broken

Created: Oct 20, 2014    Updated: Dec 19, 2017
Resolved Date: Nov 6, 2014
Found In Version: 5.0.1
Fix Version: 5.0.1.21
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

INC_PR defined in openssl_.....bb is overide by INC_PR in openssl.inc

5359a768baec538113ffd104a4f3d7433ec9f014 breaks revision for openssl.

$ head oe-core/meta/recipes-connectivity/openssl/openssl_1.0.0i.bb 
INC_PR = "r9"

CFLAG = "${@base_conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
        -DTERMIO ${CFLAGS} -Wall"


require openssl.inc

# For target side versions of openssl enable support for OCF Linux driver
# if they are available.

$grep INC_PR oe-core/meta/recipes-connectivity/openssl/openssl.inc 
INC_PR = "r1"

Workaround

none

Steps to Reproduce

build openssl and check version number

Other Downloads


Live chat
Online