Wind River Support Network

HomeDefectsLIN5-19437
Fixed

LIN5-19437 : chpasswd: PAM authentication failed

Created: Sep 8, 2014    Updated: Dec 19, 2017
Resolved Date: Sep 11, 2014
Found In Version: 5.0.1.18
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Run chpasswd on a target:
chpasswd: PAM authentication failed

Workaround

diff --git a/meta/recipes-extended/shadow/shadow.inc b/meta/recipes-extended/shadow/shadow.inc
index d1932e8..7a7242a 100644
--- a/meta/recipes-extended/shadow/shadow.inc
+++ b/meta/recipes-extended/shadow/shadow.inc
@@ -59,6 +59,7 @@ inherit autotools gettext
 EXTRA_OECONF += "--without-audit \
                  --without-libcrack \
                  --without-selinux \
+                --without-libpam  \
                  ${NSCDOPT}"
 
 NSCDOPT = ""
@@ -82,7 +83,7 @@ PAM_PLUGINS = "libpam-runtime \
 PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
 PACKAGECONFIG_class-native = ""
 PACKAGECONFIG_class-nativesdk = ""
-PACKAGECONFIG[pam] = "--with-libpam,--without-libpam,libpam,${PAM_PLUGINS}"
+//PACKAGECONFIG[pam] = "--with-libpam,--without-libpam,libpam,${PAM_PLUGINS}"
 
 RDEPENDS_${PN} = "shadow-securetty \
                   base-passwd"

Steps to Reproduce

$ wrlinux-5/wrlinux/configure --enable-board=qemux86 --enable-kernel=standard --enable-rootfs=glibc_small --with-package=shadow
$ make
$ make start-target
root@qemu1:~# echo "root:root" | chpasswd
chpasswd: PAM authentication failed
root@qemu1:~# chpasswd
chpasswd: PAM authentication failed

Other Downloads


Live chat
Online