Wind River Support Network

HomeDefectsLIN5-19351
Fixed

LIN5-19351 : Security Advisory - php - CVE-2014-3597

Created: Aug 31, 2014    Updated: Dec 19, 2017
Resolved Date: Oct 26, 2014
Found In Version: 5.0.1.21
Fix Version: 5.0.1.21
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Multiple buffer overflows in the php_parserr function in ext/standard/dns.c in PHP before 5.4.32 and 5.5.x before 5.5.16 allow remote DNS servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted DNS record, related to the dns_get_record function and the dn_expand function.  NOTE: this issue exists because of an incomplete fix for CVE-2014-4049.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3597

Other Downloads


Live chat
Online