Wind River Support Network

HomeDefectsLIN5-19062
Fixed

LIN5-19062 : Security Advisory - php - CVE-2014-3515

Created: Jul 16, 2014    Updated: Dec 19, 2017
Resolved Date: Aug 19, 2014
Found In Version: 5.0
Fix Version: 5.0.1.18
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The SPL component in PHP before 5.4.30 and 5.5.x before 5.5.14 incorrectly anticipates that certain data structures will have the array data type after unserialization, which allows remote attackers to execute arbitrary code via a crafted string that triggers use of a Hashtable destructor, related to type confusion issues in (1) ArrayObject and (2) SPLObjectStorage.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-3515

Other Downloads


Live chat
Online