Wind River Support Network

HomeDefectsLIN5-19002
Fixed

LIN5-19002 : Security Advisory - gnupg - CVE-2014-4617

Created: Jun 29, 2014    Updated: Dec 19, 2017
Resolved Date: Jul 22, 2014
Found In Version: 5.0.1.17
Fix Version: 5.0.1.17
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-4617

Other Downloads


Live chat
Online