Wind River Support Network

HomeDefectsLIN5-18520
Fixed

LIN5-18520 : Security Advisory - postgresql - CVE-2014-2669

Created: Apr 15, 2014    Updated: Dec 19, 2017
Resolved Date: Jun 14, 2014
Found In Version: 5.0
Fix Version: 5.0.1.16
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have unspecified impact via vectors related to the (1) hstore_recv, (2) hstore_from_arrays, and (3) hstore_from_array functions in contrib/hstore/hstore_io.c; and the (4) hstoreArrayToPairs function in contrib/hstore/hstore_op.c, which triggers a buffer overflow.  NOTE: this issue was SPLIT from CVE-2014-0064 because it has a different set of affected versions.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2669

Other Downloads


Live chat
Online