Wind River Support Network

HomeDefectsLIN5-18491
Fixed

LIN5-18491 : Security Advisory - openssl - CVE-2014-0160

Created: Apr 10, 2014    Updated: Dec 19, 2017
Resolved Date: Apr 10, 2014
Found In Version: 5.0.1.14
Fix Version: 5.0.1.14
Severity: Critical
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly handle Heartbeat Extension packets, which allows remote attackers to obtain sensitive information from process memory via crafted packets that trigger a buffer over-read, as demonstrated by reading private keys, related to d1_both.c and t1_lib.c, aka the Heartbleed bug. 

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0160

Other Downloads


Live chat
Online