Wind River Support Network

HomeDefectsLIN5-18333
Fixed

LIN5-18333 : Security Advisory - gnutls - CVE-2014-1959

Created: Mar 16, 2014    Updated: Dec 19, 2017
Resolved Date: May 12, 2014
Found In Version: 5.0.1.15
Fix Version: 5.0.1.15
Severity: Standard
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-1959

Other Downloads


Live chat
Online