Wind River Support Network

HomeDefectsLIN5-17950
Fixed

LIN5-17950 : export-sdk does not work on RCPL11 with multilib.

Created: Feb 4, 2014    Updated: Dec 19, 2017
Resolved Date: Feb 20, 2014
Found In Version: 5.0.1.10
Fix Version: 5.0.1.12
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: Build & Config

Description

export-sdk does not work on RCPL11 with multilib. 
it complains about missing packages. This seems to be related to the fix of LIN5-2214. 


3) make export-sdk
causes :
ERROR: Function failed: populate_sdk_image (see  workspace/gconv_prj/bitbake_build/tmp/work/qemux86_64-wrs-linux/wrlinux-image-glibc-small-1.0-r1/temp/do_populate_sdk/log.do_populate_sdk.7383 for further information)

Then I see :
error: Can't install libz1-1.2.7-r1@x86_64_nativesdk: no package provides eglibc-gconv-iso8859-1-nativesdk

With libs other than gconv we see that 'usr/lib/crtn.o' is missing in the exported sdk

Steps to Reproduce

Testcase  (wrl5-pkgs-extra-depends layer is attached to LIN5-2214)

1) /cdc/fast_prod/wrlinux50111/dvd_install/lx03_12sp/wrlinux-5/wrlinux/configure --enable-board=intel-xeon-core --enable-rootfs=glibc-std --enable-kernel=standard --enable-parallel-pkgbuilds=6 
--enable-jobs=6 --with-layer=../wrl5-pkgs-extra-depends --with-sstate-dir=../WR501_sstate --with-rcpl-version=0011
2) make fs
3) find export/dist -name gconv -exec ls {} \;
gconv-modules  ISO8859-1.so
gconv-modules  ISO8859-1.so

then 
4) make export-sdk 

Other Downloads


Live chat
Online