Wind River Support Network

HomeDefectsLIN5-13404
Fixed

LIN5-13404 : Security Advisory - glibc - CVE-2012-4412

Created: Oct 16, 2013    Updated: Dec 19, 2017
Resolved Date: Dec 17, 2013
Previous ID: LIN3-13628
Found In Version: 5.0
Fix Version: 5.0.1.11
Severity: Severe
Applicable for: Wind River Linux 5
Component/s: Userspace

Description

Integer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string, which triggers a heap-based buffer overflow.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-4412

Workaround

Unknown

Steps to Reproduce

Unknown

Other Downloads


Live chat
Online